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Night Mode Quick Access 

Enhanced Routing Turn Arrows & 
200m, 500m Voice Prompts 
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About Version and software creation date 

Load Trace Load previously saved GPS trace 

Save Trace Save a GPS trace to a file 

Load Overlays… Load map overlay of different country 

View Overlays… Preview, edit or unload overlays 

Save All Save all user settings 

Exit Exit program 

  

 

Center on GPS Automatically center map to current location 

Heading Up Map rotates in direction of travel 

Zoom to GPS Zoom in and center map to current location 

Clear Target Clear the current target 

Show GPS on … Road Display the road name of your current location 

Show Annotation Show details of map object 

Show Trace Display the trace of the route taken using GPS 

Clear Trace Clear trace from the map 

Show Scale Display scale bar 

Show Compass Display compass 

Show Navigation Pane Display road navigation information 

 

 

Jump To Go to user-defined latitude/longitude position 

Rotate Step Change the step angle for rotation 

Measure Distance Measure distance between points 

Plan Route Select Start point & Destination for route guidance 

Send SMS Send SMS through a the PDA phone 

Vehicle Command Send command to remote tracking device 

What’s Near Me Search for nearby amenities 

Tourism Information Provide useful information for tourist 

Connect to GPS Setup connection to a GPS device 

GPS Status Display GPS status information 

View NMEA Data View incoming data from GPS device 

Log GPS Data Log data from GPS device 

Playback NMEA File Playback logged positions on the map 
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ICON DESCRIPTION FUNCTION 

 Full Screen Hides the less critical buttons to offer a larger map window size 

 Switch Extends the view toolbar 

 Find Queries a location and displays it on the map 

 Waypoint Changes the properties of waypoints 

 Route Route Planning 

 Rotate  Anti-clockwise rotation 

 Rotate  Clockwise rotation 

 GPS Auto-connect to pre-set GPS device 

 Zoom In Zooms into the box you drag on the map view 

 Zoom Out Zoom out 

 Pan Pans the map as you drag the point across the map view 

 Select Selects a item 

 Extent Zooms to the extent of all overlays 

 Keyboard Standard Pocket PC input. Other input methods available. 

   Switch 
 

 Pan left Pan towards the left side of the map  

 Pan right Pan towards the right side of the map 

 Pan up Pan towards the top of the map 

 Pan down Pan towards the bottom of the map 

 Zoom In Zoom in at fixed scale 

 Zoom Out Zoom out at fixed scale 

   Waypoint 
 

 New File Creates a new waypoint file 

 Open Opens a waypoint file 

 Delete Unload the selected waypoint or waypoint file. 

 Go to Displays the selected waypoint. 

 Show/Hide Toggles display of the waypoints. 

 Link Toggles display of the lines joining the waypoints 

/  Route-Start / End Route starting point / Route ending point 

 Move up Move the selected waypoint up. 

 Move down Move the selected waypoint down. 

 Target Set target destination for directional guidance 
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About agisNavigator 

   agisNavigator is a digital street directory, which allows you to display maps on 
your Personal Digital Assistant. The main window in agisNavigator is the map window. 
Located at the bottom of the screen are the icons toolbar and menu commands toolbar. 
The icons toolbar provides zooming and panning capabilities to facilitate map navigation. 
Waypoints, with text labels, can be created to mark specific positions of interest on the 
map. Map features can be located through a simple query by keyword, after which, they 
are reflected in the map window.  

agisNavigator is copyright © of agis Pte Ltd 

agis is a registered trademark of Asia Geographic Information System Private Limited. 

Microsoft, Windows, Windows Mobile, Pocket PC and ActiveSync are trademarks of 
Microsoft Corporation in Singapore, Malaysia, the U.S. and other countries. 

Adobe, Acrobat and Acrobat Reader are trademarks or registered trademarks of Adobe 
Systems Incorporated. 

All other product names mentioned herein may be trademarks of their respective 
companies. 

agis Private Limited shall not be liable for technical or editorial errors or omissions 
contained herein. The information in this document is provided “as is” without warranty 
and is subject to change without notice. The warranties for products are set forth in the 
express limited warranty statements accompanying such products. 

This document contains proprietary information that is protected by copyright. No part if 
this document may be photocopied, reproduced, or translated to another language 
without the prior written consent of agis Private Limited. 

 

Cautions set out in this manner indicate that failure to follow 
instructions might result in loss of lives. 

 
 

Cautions set out in this manner indicate that failure to follow 
instructions might result in damage to equipment, loss of data or 
malfunction of the system. 

 

 

 

 ! 
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Abbreviations: 
PDA – Personal Digital Assistant 
GPS – Global Positioning System 
SMS – Short Message Service 
NMEA – National Marine Electronics Association 
WP – Way Point 
 
 

agisNavigator is created and owned by: 

agis pte ltd 
49 Jalan Pemimpin 
#05-11 
APS Industrial Building 
Singapore 577203 
Tel: +65 6391 4500 
Fax: +65 6298 2735 
Email: agis@asiagis.com.sg 
Website: www.asiagis.com.sg 
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Safety Information 
 
 
 

Warning! For safety, the user should not operate this system while 
driving or in motion. The user shall be responsible for his/her own 
safety and adhere to all traffic rules and regulations at all times. 
Some map data may be outdated, incomplete or inaccurate and the 
user shall exercise good judgment when using the system for route 
guidance. agis Private Limited shall not be liable for any loss or 
damage caused by the usage of the system.  

 
 

 ! 
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Important Information 
 
 
 

1. All programs and data will be lost when the PDA’s battery is 
completely drained. The user will have to re-install the agisNavigator 
with the installation CD and the serial number. 

2. The serial number provided with the agisNavigator is for installation 
on a single PDA only. Please keep it at a safe location. agis will not 
be liable for misplace or misuse of the serial number. 

3. When agisNavigator program is lost due to loss, damage or repair 
of PDA, agis will not be liable for a replacement. However, with 
supporting documents such as a police report or a repair invoice, 
replacement can be obtained. Administrative charges will apply. 

4. For upgrade of PDA, the user can bring in their old and new PDAs 
together with the installation CD and the serial number. We will 
enable the transfer of agisNavigator to the new PDA. Administrative 
charges will apply. 

5. As map data is always changing, updates can be purchased from 
our website www.asiagis.com.sg. 

6. agisNavigator has been fully tested on a limited range of PDAs in a 
given time frame. As PDA specification varies among models and/or 
batches, agis will not be liable for any incompatibility issue. 

 
 

 

http://www.asiagis.com.sg/
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1. Getting Started 
 
 
The agisNavigator is an advanced and intelligent information system that harnesses the 
cutting edge technology of Global Positioning System (GPS) and Geographical 
Information System (GIS) to provide detailed street level navigation system. 
 
agisNavigator is developed for PocketPC PDA. 
  
 
  

The map data can be purchased at www.asiagis.com 
 
 
 
 
In this section, you will learn about: 
 

� What are the system requirements? 

� Installing the agisNavigator 
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1.1 What are the system requirements? 
    
  

� PDA    
 

� PocketPC 2002 or Windows Mobile 2003  

� Memory size of about  

� Application 5MB 

� Singapore 10MB 

� Malaysia 20MB 

 

 
Please contact us to have an updated list of compatible PDAs. 

 
 
 
 
 

� Desktop or laptop 
 

� Pentium-class PC with Microsoft Windows  
 Version 98, 98SE, 2000, ME or XP Operating System 

� 40MB of free disk space 

� CD-ROM drive 

� One available serial or USB port for ActiveSync 

� Microsoft ActiveSync 3.5 and above installed 

 

 

Internet connection at the PC is required for online registration & 
software activation 
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1.2 Installing the agisNavigator 
    
  

� Setup   
 

1. Install ActiveSync if it has not been installed on your computer.  

2. Connect the PDA cradle to the PC serial or USB port 

3. Place the PDA on the cradle and power on the PDA 

4. ActiveSync will initiate connection 

 

 
When connecting the PDA to the PC for the first time, you will be prompted to 
install a driver from a CD provided with the PDA. 

 
 
 

� Installation 
 

5. Insert agisNavigator installation CD 

6. Start agisNavigator installer. 

7. You have successfully installed agisNavigator onto the PDA. 
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2. Using agisNavigator 
 
 
 
Now that you have installed agisNavigator on your PDA, you are ready for the 
experience of a life-time. 
 
 
2.1 Beginner 
 
When starting the agisNavigator for the first time, you will see a blank screen on the 
PDA. To view maps, follow the instructions below. 
 
 
 

� Loading map layers   
 

1. Tap File  

2. Tap Load Overlays 

 

 
Memory size and processor speed of PDA.  
 

Loading large maps slows down the processing speed of the PDA. At 
times, PDA might hang due to overloading. You will have to perform a 
soft reset when this occurs. Please refer to the PDA manual for 
instructions to perform a soft reset. DO NOT perform a hard reset as all 
data and program will be lost 

 
 
 

� Save settings 
 

3. Tap Save All. All your current settings will be saved. 
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2.2 Quick Links 
 
 

� Overlays 
 

 
Overlays  
Change Colour Properties 
Visibility of Overlays 
Delete Overlays  

 
 
 
 

� View 
 

 
Display or hide a set of extended buttons for map manipulation. 
Pan Left 
Pan Right 
Pan Up 
Pan Down 
Zoom In 
Zoom Out 

 
 
 
 

� Waypoints 
 

 
Waypoints are points that can be created and displayed on the map as an 
icon with label attached to it. All the waypoints can be saved in a .way file. 
 
New Waypoint File 
Open Waypoint File 
Current File 
Edit 
Delete 
Goto 
Show/Hide 
Link 
Change Image 
Move Up 
Move Down 
Set As Target 
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2.3 File Menu 
 
 
 

 
 

� About 
 
 

A brief description of the software is given. 
 
See Also 
About agisNavigator 
About agis 

 
 
 

� Load Trace 
 
Load previously saved GPS trace(s) to the program. 

1. Tap File > Load Trace. 
2. Select the trace(s) to be loaded from the list of trace (.trc) files by 

ticking the checkbox beside its filename. 
3. Tap ok to load the selected file(s) or tap the Cancel button to exit. 

 
See Also 
Save Trace  

 
 
 

� Save Trace 
 

Save the current GPS trace to a file. 

1. Tap File > Save Trace. 
2. A file dialog box will be displayed for input of File name and Notes 

for the trace. 
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3. To change the file name or folder to save the file, tap the Change 
button. Input the new file name / folder / location and tap the OK 
button. 

4. To save the trace, tap ok. 
5. To exit without saving, tap the Cancel button. 

 
See Also 
Load Trace  

 
 
 

� Load Overlays… 
 

Load agis country maps to the program. 

1. Tap File > Load Overlays…. 
2. A file dialog box will be displayed with a list of country maps. 
3. Tap the country map to be loaded.  (If overlays were removed 

previously, the user can reload all the default layers by selecting 
the country map to reload). 

4. To exit, tap the Cancel button. 

 
See Also 
Delete Overlays 
Managing Overlays 

 
 
 

� Overlays  
 

Preview all the overlays that have been loaded. 
Users can edit the colour settings (or display image) and toggle the 
visibility of the overlays. 
Overlays can also be removed from the program. 

1. Tap File > View Overlays… 
2. List of all the overlays that has been loaded are shown in a table. 
3. For Point overlays, tap the Legend field to change the display 

image for that overlay. 
4. For Line and Area overlays, tap the Legend field to change the 

colour properties for that overlay. 
5. Check/Uncheck the Overlay Name field of an overlay to toggle its 

visibility. 
6. To exit, tap ok . 

 
See Also 
Change Colour Properties 
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Visibility of Overlays 
Delete Overlays 
Add Overlays  
 
 
 

� Change Colour Properties 
 
Change the colour settings for any of the overlays. 

1. Tap File > View Overlays…. 
2. Tap the overlay's Legend field. 
3. A Change Colour dialog box will be displayed with RGB colour 

code. 
4. There are three ways to change the colour: 

- Shift the Red/Green/Blue sliders to the left or right. 
- Enter the Number code directly for Red/Green/Blue. (The values 
should be between 0 and 255) 
- Select a colour from the drop-down colour box. 

5. To apply the new colour, tap ok. 
6. To exit without applying the new colour, tap the Cancel button. 

 
 

� Visibility of Overlays 
 
Toggle the visibility of the overlays. 

1. Tap File > View Overlays… 
2. Tap the checkboxes to toggle the visibility setting of the overlays. 

(A check in the box means that the corresponding overlay is 
visible) 

3. To exit, tap ok . 

Note: File > Save All will not save the visibility settings. 
 
 
 

� Delete Overlays 
 
Delete any of the map overlays. 

1. Tap File > View Overlays… 
2. Tap the name of the overlay to be deleted. 

The name will be highlighted. 
3. Tap the Remove button. 
4. To exit, tap ok . 

 



Using agisNavigator 

 
9 

See Also 
Load Overlays  

 
 

� Save All 
 
Save all the user settings, this includes the list of overlays loaded, 
overlay's colour setting, waypoints, scale bar and compass. When the 
program next reloads, all the user settings will be preserved. 

1. Tap File > Save All. 

 
 

� Exit 
 
Exit agisNavigator. 

1. Tap File > Exit. 

Note: Remember to save the settings of the program. 
 
See Also 
Save All  
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2.4 Option Menu 
 
 

 
 
 

� Center On GPS 
 
Selecting this option will automatically pan the map window to the current 
GPS position. When the current GPS position moves to the edge of the 
map window, the map will automatically be refreshed to display the GPS 
position in the center. 

1. Tap Option > Center On GPS. 

 
 

� Heading Up / North Up 
 
When there is valid GPS data input to the program, the map can be 
rotated to reflect the direction of travel of the user. 
If map rotation is enabled, the map will be displayed such that the 
direction of motion of the user is pointing towards the top of the screen. 
If map rotation is disabled, the map will be displayed such that the North 
direction is pointing towards the top of the screen. 

1. To enable the rotation of map, tap Option > Heading Up. 
2. To disable the rotation of map, tap Option > North Up. 

 
 

� Zoom to GPS 
 
Adjust the map display and show the current GPS position at the center 
of the map. 
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1. Tap Option > Zoom to GPS. 

 
 

� Clear Target 
 
Clear the current target. 

1. Tap Option > Clear Target. 

 
� Night Mode 

 
Dim the screen display. 

1. Tap Option > Night Mode. 
2. To toggle the display, repeat Step 1. 

 
� Show GPS On Which Road 

 
When connected to GPS, the name of the current road is displayed on 
the map. 

1. Tap Option > Show GPS On Which Road. 
2. To toggle the display, repeat Step 1. 

 
� Show Annotation 

 
Show or Hide the additional details of point map objects. When this option 
is enabled, the details of point objects will be displayed on the map when 
the map is zoomed-in. 

1. Tap Option > Show Annotation. 
2. To toggle the display, repeat Step 1. 

 
 

� Show Trace 
 
When connected to GPS, a trace of the route that the user has traveled is 
displayed on the map. 

1. Tap Option > Show Trace. 
2. To toggle the display of the trace, repeat Step 1. 
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� Clear Trace 
This option clears all records of the route last �raveled by the user. 

1. Tap Option > Clear Trace. 

 
 

� Show Scale 
 
Toggle the display of the scale bar shown at the bottom left corner of the 
screen. 

1. Tap Option > Show Scale. 
2. To toggle the display of the scale bar, repeat Step 1. 

 
 

� Show Compass 
 
Toggle the display of the compass shown at the bottom right corner of the 
screen. 

1. Tap Option > Show Compass. 
2. To toggle the display of the compass, repeat Step 1. 

 
 

� Show Navigation Pane 
 
When GPS is connected, navigation information can be displayed at the 
top of the screen. 

1. Tap Option > Show Navigation Pane. 
2. To toggle the display of the navigation information, repeat Step 1. 
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2.5 Tool Menu 
 
 

                                  
 
 

� Jump To 
 
Translate the map to a user defined latitude/longitude position. 

1. Tap Tools > Jump To… . 
2. Select the mode, 

i) Degrees (d.d°),  
ii) Degree/Minutes (d°m.m’) or  
iii) Degree/Minute/Seconds (d°m’s”). 

3. Select the direction of the latitude (North or South) and longitude 
(East or West). 

4. Enter the latitude and longitude values. 
5. To create a waypoint on jumping to that position, tick the Creating 

Waypoint checkbox. 
6. To jump to the position, tap the Jump To button. 
7. To exit, tap the ok button. 

 
 

� Rotate Step 
 
Set the step size for map rotation. 

1. Tap Tools > Rotate Step… . 
2. Enter the new value for the angle of clockwise rotation. 
3. To restore default settings, tap the Default button. 
4. To save the new value and exit, tap ok. 
5. To exit without changes, tap the Cancel button. 
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� Measure Distance 

 
Measure the actual ground distance(s) between 2 (or more) points on the 
map. 

1. Tap Tools > Measure Distance. 
2. A popup bar will appear at the top right corner of the screen. 
3. Tap the first position on the map. 
4. Tap the second position on the map. 
5. The measured distance will be displayed. 
6. To continue with the measurement, tap another position(s) to 

continue. The total distance from the first position will be shown. 
7. To start a new measurement, tap the New button. 
8. To exit from measurement mode, tap the X button. 

 
� Plan Route 

 
Plan the route to take during travel between a start and end location. 
 

1. Tap Tools > Plan Route. 
2. A Planning screen will be displayed. 
3. Select a starting point. 
4. Select a destination 
5. Select either the “fastest” or “shortest” routing option. 
6. Select whether to enable automatic reroute. 
7. Select whether to set the destination point as a target. 
8. Tap the Reverse button to reverse the starting and destination 

points. 
9. To cancel, tap the Cancel button. 

 
See Also 
Routing 
 

- Advance User Only - 
 

� Send SMS 
 
Send a SMS through the active SMS connection. 

1. After a SMS connection is established, tap Tools > Send SMS... . 
2. In the Send SMS screen, enter the contact number of the 

recipient by filling up the text box on the top-left of the screen. 
3. Tap the -> button to create new contact information. 
4. Alternatively, select a name from the list of available contacts in 

the drop-down list on the top-right of the screen. 
5. Fill in the message to be sent. (Maximum message length is 160 

characters) 
6. Tap the Send button to send the message. 
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7. To Cancel without sending message, tap the ok button. 

 
- Advance User Only - 

 
� Vehicle Command 

 
Send Vehicle Command SMS to an agis GPS tracking device. (Please 
contact agis to find out more about tracking devices) 

1. After a SMS connection is established, tap Tools > Vehicle 
Command... . 

2. In the Vehicle Command screen, first select the Asset type.  
3. Next, select the recipient from the drop-down list. 
4. Tap Locate Asset to retrieve latitude and longitude position of the 

selected asset. 
5. Tap Lock Asset to lock the asset. 
6. Tap Unlock Asset to unlock the asset. 
7. Tap Enable Asset to enable tracking of the asset. 
8. Tap Disable Asset to disable tracking of the asset. 
9. To exit, tap the ok button. 

 
- Advance User Only - 

 
� What's Near Me 

 
Find out what is near your proximity. Your present location is based on 
the GSM Base station. (This service requires subscription with your telco) 

1. Tap Tools > What's Near Me. 

 
- Advance User Only - 

 
� Tourism Information 

 
A new window will be shown to display Tourism Information. (Only for 
subscriber) 

1. Tap Tools > Tourism Information. 

 
� Connect to GPS 

 
Setup the connection to a GPS device. 

1. Tap Tools > Connect GPS or tap the  button (enabled if GPS 
settings have been set). 
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2. At the Data Connection Settings screen, select the Port from the 
list of available connections. 

3. Select the appropriate Baud rate for the selected connection. 
4. Tap ok to confirm the settings and connect to the selected GPS 

device. 
5. To Cancel, tap the Cancel button. 

Note: An icon will be placed at the bottom right of the screen to indicate 
the status of the GPS position fix. 
 
See Also 
Disconnect GPS 
GPS Status 
View NMEA Data  
 
 
 

� Disconnect GPS 
 
Disconnect from the GPS device. 

1. To terminate an active GPS connection, tap Tools > Disconnect 
GPS. 

 
 

� GPS Status 
 
Display GPS status information based on data received from the GPS 
receiver. 

1. After a GPS connection is established, tap Tools > GPS Status... . 
2. Tap the Position tab to view the current position information. 
3. Tap the Skyplot tab to view the position of the satellites in the sky. 
4. Tap the Signal Strength tab to view the signal level of signals 

received from the satellites. 
5. To exit, tap ok.  

See Also 
View NMEA Data  
 
 
 

� View NMEA Data 
 
Allow the user to view the NMEA message received from the GPS device. 

1. After a GPS connection is established, tap Tools > NMEA Data... . 
2. In the View NMEA Message screen, NMEA messages received 

from the GPS device is displayed in a scrollable list. 
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3. To pause the updating of the list, tick the Pause checkbox. 
4. To resume the updating of the list, un-tick the Pause checkbox. 
5. To exit, tap ok. 

See Also 
Log GPS Data 
GPS Status 
 
 
 

� Log GPS Data 
 
NMEA data received from the GPS device can be saved to a file on the 
PDA. 

1. Tap Tools > Log GPS Data... . 
2. At the Logging GPS Data screen, select either 

  - Full GPS Data logging or 
  - Partial GPS Data logging. 

3. The Full GPS Data logging option will log all NMEA data received 
from the GPS device. 

4. The Partial GPS Data logging option allows selective logging from 
a choice of 5 predefined NMEA data types. 
The logging interval can also be selected. 

5. A default filename for the GPS log file is displayed. 
To change this filename, tap the name to edit it directly or tap the 
Change button. 

6. Tap the Start logging button to begin logging of GPS data. 
7. To exit without logging, tap ok . 

See Also 
View NMEA Data 
GPS Status 
 
 
 

� Playback NMEA File 
 
Retrieve GPS data from a NMEA log file and display the positions in the 
log file as a route on the map. 

1. Tap Tools > Playback NMEA File. 
2. A Open file dialog will be shown for selection of a NMEA log file. 
3. Select a file by tapping on its name. 
4. The positions in the file will be shown as a route on the map. 
5. To stop the playback, tap Tools > Stop Playback. 
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2.6 Map Menu 
 
 

 
 

 
 

� How to display the Map Menu 
 
To display the Map Menu, tap a location on the map and hold the stylus 
down for about 2 seconds. 
 
 
 
 

� Map > New WP 
 
Creates a new waypoint at the current map location. 

1. Tap a location on the map and hold the stylus down for about 2 
seconds. 

2. Select Map > New WP from the map menu. 
3. A new waypoint will be created at the current location and added 

to the current waypoint file. 

 
 

� Map > Set As Target 
 
Set the current screen location as the target for GPS navigation. 

1. Tap a location on the map and hold the stylus down for about 2 
seconds. 

2. Select Map > Set As Target from the map menu. 
3. The current screen location will be set as the target for GPS 

navigation and a target icon  will be shown at this location. 

 
 
 

� Map > What's Nearby 
 
Allows the user to search for map items in the vicinity of the current 
screen location. 
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1. Tap a location on the map and hold the stylus down for about 2 
seconds. 

2. Select Map > What's Nearby from the map menu. 
3. Select the Search Range from the drop-down list. 
4. Select one or more type of Amenities to search for by ticking the 

checkbox beside the name of the Amenity. 
5. Tap Search to start searching. 
6. The result of the search will be listed. 

(If no result is found, the list will be empty.) 
7. To view an item on the map, tap the item's name to select it, then 

tap the Go To button to go to the map view. 
8. To view all the listed items on the map at the same time, tap the 

View All button to go to the map view. 
9. To search again, tap the Back button. Then repeat Steps 3 to 5. 
10. To exit without selecting any item, tap ok . 

 
 
 

� Routing 
 
Allows the user to obtain a recommended route between 2 locations on 
the map. 
In order to perform a route computation, a start location and an end 
location must be selected. 
 
 
Selecting the Start Location 
There are 4 methods to select the start location: 

1. Tap the Tools > Plan Route option to access the full route 
planning window. 

2. Tap the intended start location of the route in the map view and 
hold the stylus down for about 2 seconds. 
Next, select Map > Route - Start Point from the map menu to set 
this location as the start location. 

3. Perform a Find operation. 
In the search results list, tap the name of the desired item to select 
the item. 
Tap on the name of this item and hold the stylus down for about 2 
seconds. 
Select Set Route Start Point from the pop-up menu. 

4. Tap the Waypoints button.  
Select the waypoint to be set as the start location. 
Tap on the start route button.  
Select Set Route Start Point from the pop-up menu. 

 

Selecting the End Location 
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Similarly, there are 4 methods to select the end location: 

1. Tap the Tools > Plan Route option to access the full route 
planning window. 

2. Tap the intended end location of the route in the map view and 
hold the stylus down for about 2 seconds. 
Next, select Map > Route - End Point from the map menu to set 
this location as the start location. 

3. Perform a Find operation. 
In the search results list, tap the name of the desired item to select 
the item. 
Tap on the name of this item and hold the stylus down for about 2 
seconds. 
Select Set Route End Point from the pop-up menu. 

4. Tap the Waypoints button.  
Select the waypoint to be set as the start location. 
Tap on the end route button.  
Select Set Route End Point from the pop-up menu. 

Computing the Route 

1. After selecting the Start and End locations, a Routing Setting 
window will be displayed. 

2. Select the routing method (either Fastest or Shortest route). 
3. Tap the Start button to start the route computation. 
4. Once the route computation is completed, the recommended route 

will be displayed on the map. 

Note: 

•  To perform another route computation, select Map > Clear 
routing from the Map Menu to clear the current route display. 
Then select the new Start and End Locations. 

•  If a GPS device is connected and the user travels along the 
recommended route, voice turning instructions will be given at the 
500m, 200m junctions and before the junction itself. In addition, 
turn directions will be clearly displayed on the map screen. 

See Also 
Routing 
 
 

 
- Advance User Only – 

-  
� Map > Send Pos To… 

 
Allows the user to send his current position to the intended recipient. This 
function is only available for PDA with built-in phone functionalities. 
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1. Tap a location on the map and hold the stylus down for about 2 
seconds. 

2. Select Map > Send Pos To… from the map menu. 
3. In the Send Current Position To… screen, enter the contact 

number of the recipient by filling up the text box on the top-left of 
the screen. 

4. Tap the -> button to create new contact information. 
5. Alternatively, select a name from the list of available contacts in 

the drop-down list on the top-right of the screen. 
6. Tap the Send button to send the message. 
7. To Cancel without sending message, tap the ok button. 
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2.7 Lower Toolbar 
 
 

 
 

 
 

� Zoom In 
 
There are two ways of zooming into a map window. 
 
First Method 

1. Tap the Zoom In button  and the button will remain depressed. 
2. Draw a box on the map window and the window will zoom into the 

area selected. 
3. To exit zoom in mode, tap the Select button.   

Second Method 

1. Tap the Zoom In button and the button will remain depressed. 
2. Tap on the map window where you want to zoom in. This will 

zoom in by a factor of 2. 
3. To exit zoom in mode, tap the Select button.   

 
 
 

� Zoom Out 

1. Tap the Zoom Out button  and the button will remain depressed. 
2. Tap on the map window. This will zoom out by a factor of 0.5.  
3. To exit zoom out mode, tap the Select button.  

 
 

� Pan 

1. Tap the Pan button  and the button will remain depressed. 
2. Drag over the map window to do a pan operation. 
3. To exit pan mode, tap the Select button.  

 
 

� Select 
Disable zoom in, zoom out and pan operations. 
Enable selection of items in a map window. 
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1. Tap the Select button  on the toolbar. 
2. Tap on any item on the map. 
3. The attributes of the item selected will pop-up as a message box. 

 
 

� Home 
 

 Zooms to the extent of all overlays. 
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2.8 Upper Toolbar 
 
 

 
 
 
 

� Fullscreen 
 
Hides some of the less critical buttons and menus to offer a larger map 
window size. 
 
 
 

� Find 
 
Query a location or map feature and reflect it on the map. 

1. Tap the Find button.  
2. Select the layer that you want to query from the drop-down list. 

(To search all map layers, tick the All checkbox) 
3. Enter a keyword in the text box. 
4. Tap the Search button. 
5. The search result will be listed in the text area at the bottom of the 

screen. 
(If there is no result, there will be a message "Sorry, No item 
found".) 

6. Highlight the location you wish to see on the map. 
7. To create a waypoint at the selected location, tick the Creating 

WP checkbox. 
8. To set the selected location as a target for navigation, tick the Set 

As Target checkbox. 
9. Tap the Go To button and this location will be displayed on the 

map. 
10. Alternatively, to view All the items found in Step 5 on the map at 

the same time, tap the View All button. 

 
� Plan Route 

 
Direct access to the Plan Route function. Similar to the Tools > Plan 
Route function. 
 

1. Tap the Plan Route button.  
 
 
See Also 
Plan Route 
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� Rotate Anti-clockwise 
 
Rotate the map view anti-clockwise by the amount specified in Tools > 
Rotate Step... . 
 
 
 

� Rotate Clockwise 
 
Rotate the map view clockwise by the amount specified in Tools > 
Rotate Step... . 
 
 

� GPS Connection 
 
Enables automatic connection to the configured GPS device (if previously 
configured).  
Similar to the Tools > Connect to GPS function. 
 

1. Tap the GPS connection button.  
 
 
See Also 
Connect To GPS 
 
 
 
 

 
 
 

� View > Pan Left 
 
Shifts the view of the map to the left. 

1. Tap the View button.  
2. Tap the Pan Left button  to move the map. 
3. To exit, Tap the View button.  

 
 

� View > Pan Right 
 
Shifts the view of the map to the right. 

1. Tap the View button.  
2. Tap the Pan Right button  to move the map. 
3. To exit, Tap the View button.  
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� View > Pan Up 
 
Shifts the view of the map upwards. 

1. Tap the View button.  
2. Tap the Pan Up button  to move the map. 
3. To exit, Tap the View button.  

 
 

� View > Pan Down 
 
Shifts the view of the map downwards. 

1. Tap the View button.  
2. Tap the Pan Down button  to move the map. 
3. To exit, Tap the View button.  

 
 

� View > Zoom In 
 
Zooms in by a factor of 2. 

1. Tap the View button.  
2. Tap the Zoom In button.  
3. To exit, Tap the View button.  

 
 

� View > Zoom Out 
 
Zooms out by a factor of 0.5. 

1. Tap the View button.  
2. Tap the Zoom Out button.  
3. To exit, Tap the View button.  
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2.9 Waypoint 
 
 

 
 
 
 

� Waypoints > Create 
 
There are four methods to add waypoint to the default waypoint file. 
First Method 

1. Use the Find feature. 

Second Method 

1. Hold the stylus over a position on the map window for a second. 
2. Select "New WP" from the pop-up menu and a new waypoint will 

be created with a default icon. 
3. Tap the Waypoints button  to edit the waypoints. 

Third Method 

1. Use the Jump To feature. 

Fourth Method 

1. When connected to a GPS receiver and there is a position fix, tap 
the Satellite button  to create a way point at the current location. 

 
See Also 
Waypoints > Edit 
 
Find 
Jump To 
Connect To GPS  
 
 
 

� Waypoints > Edit 
 
Edit the name of waypoint and add notes to waypoint. 

1. Tap the Waypoints button.  
2. Select the waypoint to be edited. 
3. Edit the name of the waypoint from the text box. 
4. User can also add notes at the text area. 
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See Also 
Waypoints > Create  
 
 
 

� Waypoints > New Waypoint File 
 
Create a new waypoint file to store the waypoints. 

1. Tap the Waypoints button.  
2. Tap the New Waypoint File button.  
3. A Save As window will appear for you to specify the file name and 

the location to save the new file. 
4. To confirm the file name, tap the OK button. 
5. This new waypoint file will automatically become the "Current File" 

where new waypoints are stored. 

 
See Also 
Waypoints > Open Waypoint File 
Waypoints > Delete 
Waypoints > Current File  
 
 
 

� Waypoints > Open Waypoint File 
 
Loads agis waypoint files. The default waypoint file is "general.way".  

1. Tap the Waypoints button.  
2. Tap the Open Waypoint File button.   
3. Select the waypoint file to be loaded. 

 
See Also 
Waypoints > New Waypoint File 
Waypoints > Delete  
 
 
 

� Waypoints > Current File 
 
All new waypoints are added to the Current waypoint file. If there are 
more than one waypoint file loaded, only one file can be made Current.  

1. Tap the Waypoints button.  
2. Select the waypoint file to be made Current. 
3. Tick the Current File checkbox to make the selected waypoint file 

as the Current File. 



Using agisNavigator 

 
29 

 
See Also 
Waypoints > New Waypoint File 
Waypoints > Open Waypoint File  
 
 
 
 

� Waypoints > Delete 
 
Delete individual waypoint or remove waypoint file. 
 
Delete a waypoint  

1. Tap the Waypoints button.  
2. Select the waypoint to be deleted. 
3. Tap the Delete button.  
4. Tap Yes to confirm the deletion of the selected waypoint. 

Remove a waypoint file  

1. Tap the Waypoints button.  
2. Select the waypoint file to be removed. 
3. Tap the Delete button.  
4. Tap Yes to confirm the removal of the selected waypoint file. 

Note: 
The waypoint file is unloaded but is not deleted from memory. The 
same waypoint file can be loaded again if desired. 

 
See Also 
Waypoints > New Waypoint File 
Waypoints > Open Waypoint File  
 
 
 

� Waypoints > Goto Waypoint 
 
Redraw the map to display the selected waypoint. 

1. Tap the Waypoints button.  
2. Select the waypoint of interest. 
3. Tap the Goto Waypoint button.  
4. The map view will be adjusted to display the selected waypoint. 

 
 

� Waypoints > Show/Hide 
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Toggles the display of the waypoints on the map. 

1. Tap the Waypoints button.  
2. Select the waypoint of interest. 
3. If the selected waypoint is currently visible , tap this button to 

turn it invisible. 
4. If the selected waypoint is currently invisible , tap this button to 

turn it visible. 

Note: 
To toggle the display state of all waypoints in a waypoint file, select the 
waypoint file in Step 2.  
 
 
 

� Waypoints > Link/Unlink 
 
Toggles the display of the lines joining the waypoints on the map. 

1. Tap the Waypoints button.   
2. Select the waypoint or waypoint file of interest. 
3. If the waypoints in the selected waypoint file is currently linked , 

tap this button to unlink them.  
4. If the waypoints in the selected waypoint file is currently unlinked 

, tap this button to link them.  

 
 

� Waypoints > Change Image 
 
Change the display image for a waypoint or waypoint file. 

1. Tap the Waypoints button.  
2. Double tap on the waypoint of interest. 
3. Select the new image for the waypoint. 

Note: 
To change all the waypoints in a waypoint file to the same image, select a 
waypoint file instead of a single waypoint in Step 2.  
 
 
 

� Waypoints > Move Up 
 
Move the position of a waypoint forward within a waypoint file. 

1. Tap the Waypoints button.  
2. Select the waypoint of interest. 
3. Tap the Move Up button.  
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Note: 
If the selected waypoint is the first waypoint in the waypoint file, its 
position will not be changed.  
 
 
 

� Waypoints > Move Down 
 
Move the position of a waypoint backwards within a waypoint file. 

1. Tap the Waypoints button.  
2. Select the waypoint of interest. 
3. Tap the Move Down button.  

Note: 
If the selected waypoint is the last waypoint in the waypoint file, its 
position will not be changed.  
 
 
 

� Waypoints > Set As Target 
 
Set a waypoint as a target for GPS navigation. 
A line joining the current GPS position and the target will be shown on the 
map.  

1. Tap the Waypoints button.  
2. Select the waypoint of interest. 
3. Tap the Set As Target button.  

See Also 
Clear Target 
 
 
 

� Attributes 
 
View the attribute of an selected item. 

1. Tap the Select button.  
2. Tap on any item on the map. 
3. It's attribute will be displayed on the screen in the form of a pop up 

box. 
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APPENDIX A – Troubleshooting 
 
 

 
Installation error 

Error Message Cause Solution 

No license file is found. >incomplete installation 
>license file was deleted >reinstall 

License is illegal. >license file is corrupted >reinstall 

The license is not for this 
PDA. 

>installation serial number is 
registered under another 
device 

>purchase new serial 
number 

The license file is invalid. >wrong version >contact us 

Routing error 

Error Message Cause Solution 

Limit Exceeded >resource exceeded  
>re-route via fastest 
option 
>shorten route 

At least one selected point 
is outside routing area! 

>missing rtl file 
>invalid routing start/end point 

>reinstall 
>select a start/end point 
on a valid road 

route.bin not found >missing bin file >restart application, if not 
>reinstall 
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APPENDIX B – Optional Accessories 
 
 
 

 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
  
 

Bluetooth GPS 
receiver 

Car PDA holder
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